Deposit and withdrawal notice

Incident Report for dYdX Chain

Resolved

This incident has been resolved.
Posted 13 days ago. Mar 18, 2025 - 20:33 UTC

Investigating

USDC deposits and withdrawals via Ethereum, Arbitrum, Optimism, Avalanche, Polygon, Base, and Solana will temporarily incur higher fees and longer finalization times due to ongoing maintenance by Circle—one of dYdX’s onboarding partners. Transactions on these networks may experience delays however, all existing USDC deposits and withdrawals will be processed once Circle restores service.

For more details, see here.
Posted 14 days ago. Mar 18, 2025 - 06:09 UTC
This incident affected: Frontend (dydx.trade).