Ethereum Bridge transactions are not being acknowledged on chain
Incident Report for dYdX Chain
Resolved
Bridge transaction acknowledgements have caught up on chain.

Reminder that validators are encouraged to check their Ethereum RPC is set up correctly:

1. Query for `recognized-event-info` on your node: `$ dydxprotocold query bridge get-recognized-event-info`.

2. Check the output `next_id` match the latest next bridge ID on the Ethereum contract. To find this latest ID, see `_nextAvailableBridgeId` on the Ethereum bridge contract https://etherscan.io/address/0x46b2deae6eff3011008ea27ea36b7c27255ddfa9#readContract. As the current time of update, `next_id` from `get-recognized-event-info` should be at least `227`.

3. If your node does not have the correct `next_id`, please refer to instructions here to set up a valid Ethereum RPC endpoint: https://docs.dydx.trade/mainnet/genesis/starting_the_network#important-ethereum-rpc-endpoint
Posted Oct 30, 2023 - 16:14 UTC
Update
FYI for validators: nodes need to be set up with a valid Ethereum RPC endpoint to recognize latest Ethereum Bridge events. To verify this:

1. Query for `recognized-event-info` on your node: `$ dydxprotocold query bridge get-recognized-event-info`.

2. Check the output `next_id` match the latest next bridge ID on the Ethereum contract. To find this latest ID, see `_nextAvailableBridgeId` on the Ethereum bridge contract https://etherscan.io/address/0x46b2deae6eff3011008ea27ea36b7c27255ddfa9#readContract. As the current time of update, `next_id` from `get-recognized-event-info` should be at least `227`.

3. If your node does not have the correct `next_id`, please refer to instructions here to set up a valid Ethereum RPC endpoint: https://docs.dydx.trade/mainnet/genesis/starting_the_network#important-ethereum-rpc-endpoint
Posted Oct 30, 2023 - 00:42 UTC
Investigating
The dYdX Chain is currently not recognizing bridge transactions from Ethereum. This issue is being investigated.
Posted Oct 30, 2023 - 00:18 UTC
This incident affected: dYdX Chain (Protocol).