Elevated frontend loading time

Incident Report for dYdX Chain

Resolved

This incident has been resolved.
Posted Mar 04, 2025 - 19:40 UTC

Investigating

We are investigating an issue which is affecting FE loading time for a subset of users. dYdX Chain/Indexer remains functional.
Posted Mar 04, 2025 - 16:42 UTC
This incident affected: Frontend (dydx.trade).